Engine Yard Developer Center

Engine Yard Cloud Updates June 2012

The updates described are either important (where you need to take action) or of interest (you might want to know about these changes but you don't need to do anything).

Minor: Early Access: RubyGems drop-down in the environment UI

June 28th, 2012

Action: This is an optional Early Access release. No action required.

This feature allows you to choose the appropriate RubyGems version for your environment. For example, an older version of Rails would need a different RubyGems version than the default.

Enable the RubyGems feature

You need to enable the Early Access feature before you can participate in the program.

To enable the RubyGems Early Access

  1. Log in to your account.

  2. In Engine Yard Cloud, click Account > Account Settings on the toolbar.

  3. On the account settings page, click Manage Early Access Features.

  4. Next to the RubyGems drop-down feature, click Enable.

Use the RubyGems feature

The next time you go to the environment UI, the RubyGems drop-down will appear.

RubyGems_dropdown.png

To get to the environment UI

  • From your new app's Environments page, click Create New Environment.

  • For your existing environment, click Edit Environment under the More Options section.

HOTFIX for missing /mnt volume on 64-bit medium instances

June 26th, 2012

Action: You automatically apply these changes the next time you click the Upgrade button for your environment.

We pushed a fix for users who experienced an issue with missing /mnt volume, which affected a subset of 64-bit medium instances.

Major: Engine Yard Gem 2.0.0-rc1 Early Access

June 21st, 2012

Action: This is an optional Early Access release from the open source project. No action required.

The following changes to the Engine Yard Gem are currently available in Early Access:

    • Uses git commands and environment variables (GIT_DIR and GIT_WORK_TREE) to more appropriately use your repository for some actions (for example, you can use the Engine Yard CLI when you are not in the same directory as the git repository).
    • Increases responsiveness of most API interactions.
    • Prints notices when ey.yml defaults are used.
    • Improves failed deployment output messaging.
    • Allows --app, --account, and --environment for ey environments for extra filtering.
    • Prints an error when a command line option, like --environment, is specified without an argument.
    • Implements new version of engineyard-serverside (and adapter), which includes:
      • Default bundler version is now 1.1.5.
      • Deploy hooks now have access to account_name and environment_name.
      • Improves deploy output, especially for --verbose.
      • Sends all log output through a new Shell object that formats and adds timestamps.
      • Loads ey.yml or config/ey.yml to customize deploy settings.
      • Supports new ey.yml options to control automatic maintenance page:
        • maintenance_on_restart: true or false (default: false except for glassfish and mongrel).
        • maintenance_on_migrate: true or false (default: true).
      • If the settings for maintenance_on_restart and maintenance_on_migrate are false, then the deploy process will not remove maintenance pages that were installed using ey web disable. (If you installed a maintenance page manually, the deploy process removes the maintenance page automatically only if the deploy would have automatically installed the page originally.)
      • Supports new ey.yml option to control asset pre-compilation:
        • precompile_assets: true or false (default: inferred using app/assets and config/application.rb).
      • Supports new ey.yml option to ignore the missing database adapter warning:
        • ignore_database_adapter_warning: true (default: false)

Minor: Engine Yard stack upgrade

June 19th, 2012

Action: You automatically apply these changes the next time you click the Upgrade button for your environment.

The following changes have been made to the Engine Yard stack:

  • Allows changing Nginx behavior during main Chef run: reload the config, restart Nginx, or do nothing. (You need to contact Engine Yard Support to enable this feature.)
  • Upgrades Ruby Enterprise Edition (REE) version to 1.8.7.2012.02.
  • Enables support for named slaves by writing custom database slave names to database.yml.
  • Fixes RubyGems version install issue that occurs when combined with a Ruby version downgrade.
  • Fixes Rubinius 1.9 installation issues. (Rubinius is an Early Access feature.)

Minor: Engine Yard stack upgrade

June 12th, 2012

Action: You automatically apply these changes the next time you click the Upgrade button for your environment.

The following changes have been made to the Engine Yard stack:

  • Fixes problem with Stunnel start.
  • Increases innodb_buffer_pool_size on standard medium instances.
  • Upgrade Node Nginx to version 1.0.15. (Node is an Early Access feature.)
  • Makes God properly reload its config on Node application setup. (Node is an Early Access feature.)

HOTFIX for V8 asset compile error

June 6th, 2012

Action: You automatically apply these changes the next time you click the Upgrade button for your environment.

We pushed a fix for users who experienced an issue when pre-compiling Rails assets due to a shared library v8 error.

Minor: Engine Yard stack upgrade

June 5th, 2012

Action: You automatically apply these changes the next time you click the Upgrade button for your environment.

The following changes have been made to the Engine Yard stack:

  • Enables httpchk support in HAProxy by using environment metadata.
  • Fixes deployment issue where a new app fails to get added when Memcached recipe runs too early in multi-app environments.
  • Fixes missing default swap volumes for High-CPU/Medium 64-bit and Standard/Medium 64-bit instance types.
  • Corrects issue with Standard/Small 64-bit instance types missing default swap volumes.
  • Adds support for detecting appropriate RubyGems version at cookbook upgrade time. When you click the Upgrade button for this release, RubyGems will no longer be upgraded automatically.

If you have feedback or questions about this page, add a comment below. If you need help, submit a ticket with Engine Yard Support.

Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request

Comments

Please sign in to leave a comment.

Powered by Zendesk