Engine Yard Developer Center

Engine Yard Release Notes - March 2015

Engine Yard Stack Release Notes for March 20th, 2015

Hotfix: Engine Yard Gentoo 2009 stack upgrade

Action: We recommend you test this hotfix in your staging environment as soon as possible; then, when that is validated, click the Upgrade button for your production environment.

Note: For clarity, since we now have 2 Gentoo stacks, we refer to this stack as the "Engine Yard Gentoo 2009" stack. You can access it by using the Stack select field in the Environment UI:

stack_stable-v2.png

It's best practice to upgrade your Engine Yard Gentoo 2009 (stable-v2) stack regularly for the latest security and product updates. This week's updates:

  • Upgrades OpenSSL to 0.9.8zf to address several security vulnerabilities

    Note: After upgrading to this release, running processes will continue to use the previously installed openssl library.  Manual intervention on your part will be required to restart those processes after upgrading. To determine which processes need to be restarted, you can run lsof | grep 'DEL.*openssl'.  If you need help, please open a ticket with our support team.

For more information on Engine Yard Gentoo 2009, see the Engine Yard Gentoo 2009 docs. 


Hotfix: Engine Yard Gentoo 12.11 stack upgrade

Action: We recommend you test this hotfix in your staging environment as soon as possible; then, when that is validated, click the Upgrade button for your production environment.

Note: For clarity, since we now have 2 Gentoo stacks, we refer to this stack as the Engine Yard Gentoo 12.11 stack. You can access it by using the Stack select field in the Environment UI:

stack_stable-v4.png

It's best practice to upgrade your Engine Yard Gentoo 12.11 (stable-v4) stack regularly for the latest security and product updates. The following critical issues were resolved with this update:

  • Upgrades OpenSSL to 1.0.0r (Also makes available 0.9.8zf and 1.0.1m) to address several security vulnerabilities

    Note: After upgrading to this release, running processes will continue to use the previously installed openssl library.  Manual intervention on your part will be required to restart those processes after upgrading. To determine which processes need to be restarted, you can run lsof | grep 'DEL.*openssl'.  If you need help, please open a ticket with our support team.

For more information on Engine Yard Gentoo 12.11, see the Engine Yard Gentoo 12.11 docs.

Engine Yard Stack Release Notes for March 18th, 2015

Hotfix: Engine Yard Gentoo 12.11 stack upgrade

Action: We recommend you test this hotfix in your staging environment as soon as possible; then, when that is validated, click the Upgrade button for your production environment.

Note: For clarity, since we now have 2 Gentoo stacks, we refer to this stack as the Engine Yard Gentoo 12.11 stack. You can access it by using the Stack select field in the Environment UI:

stack_stable-v4.png

It's best practice to upgrade your Engine Yard Gentoo 12.11 (stable-v4) stack regularly for the latest security and product updates. The following critical issues were resolved with this update:

  • Fixes chef error that was encountered on non-Ruby environments when upgrading to the release of March 17th, 2015.

For more information on Engine Yard Gentoo 12.11, see the Engine Yard Gentoo 12.11 docs.

Engine Yard Stack Release Notes for March 17th, 2015

The updates described are either important (where you need to take action) or of interest (you might want to know about these changes but you don't need to do anything).

Minor: Engine Yard Gentoo 2009 stack upgrade

Action: You apply the following changes the next time you click the Upgrade button for your Engine Yard Gentoo 2009 environment.

Note: For clarity, since we now have 2 Gentoo stacks, we refer to this stack as the Engine Yard Gentoo 2009 stack. You can access it by using the Stack select field in the Environment UI:

stack_stable-v2.png

It's best practice to upgrade your Engine Yard Gentoo 2009 (stable-v2) stack regularly for the latest security and product updates. This week's updates:

  • Stop monitoring the postgres & template1 databases on PostgreSQL servers.
  • Upgrades pg_top to version to 3.7.0 to work with newer PostgreSQL major versions.
  • Upgrades OpenSSL to 0.9.8zd

    Note: After upgrading to this release, running processes will continue to use the previously installed openssl library.  Manual intervention on your part will be required to restart those processes after upgrading. To determine which processes need to be restarted, you can run lsof | grep 'DEL.*openssl'.  If you need help, please open a ticket with our support team.

For more information on Engine Yard Gentoo 2009, see the Engine Yard Gentoo 2009 docs.


Minor: Engine Yard Gentoo 12.11 stack upgrade

Action: You apply the following changes the next time you click the Upgrade button for your Engine Yard Gentoo 12.11 environment.

Note: For clarity, since we now have 2 Gentoo stacks, we refer to this stack as the Engine Yard Gentoo 12.11 stack. You can access it by using the Stack select field in the Environment UI:

stack_stable-v4.png

It's best practice to upgrade your Engine Yard Gentoo 12.11 (stable-v4) stack regularly for the latest security and product updates. This week's updates:

  • Adds Early Access support for Ruby 2.2, including using Nginx 1.6.2 with OpenSSL 1.0.1 support for TLS 1.1/1.2.
  • Stop monitoring the postgres & template1 databases on PostgreSQL servers.
  • Upgrades pg_top to version to 3.7.0 to work with newer PostgreSQL major versions.
  • Upgrades OpenSSL to 1.0.0p (Also makes available 0.9.8zd and 1.0.1k)

    Note: After upgrading to this release, running processes will continue to use the previously installed openssl library.  Manual intervention on your part will be required to restart those processes after upgrading. To determine which processes need to be restarted, you can run lsof | grep 'DEL.*openssl'.  If you need help, please open a ticket with our support team.

For more information on Engine Yard Gentoo 12.11, see the Engine Yard Gentoo 12.11 docs.


Engine Yard Stack Release Notes for March 6, 2015

The updates described are either important (where you need to take action) or of interest (you might want to know about these changes but you don't need to do anything).

Minor: Engine Yard Gentoo 2009 stack upgrade

Action: You apply the following changes the next time you click the Upgrade button for your Engine Yard Gentoo 2009 environment.

Note: For clarity, since we now have 2 Gentoo stacks, we refer to this stack as the Engine Yard Gentoo 2009 stack. You can access it by using the Stack select field in the Environment UI:

stack_stable-v2.png

It's best practice to upgrade your Engine Yard Gentoo 2009 (stable-v2) stack regularly for the latest security and product updates. This week's updates:

  • Enhances collectd monitoring and performance graphs for ext4 and swap devices, removes redundant mysql check.
  • Corrects issue with missing /dev/sdz2 symbolic link causing chef runs on db replicas to fail after rebooting.
  • Fixes issue with swap not being correctly created on c1.medium and m1.small instances

For more information on Engine Yard Gentoo 2009, see the Engine Yard Gentoo 2009 docs.


Minor: Engine Yard Gentoo 12.11 stack upgrade

Action: You apply the following changes the next time you click the Upgrade button for your Engine Yard Gentoo 12.11 environment.

Note: For clarity, since we now have 2 Gentoo stacks, we refer to this stack as the Engine Yard Gentoo 12.11 stack. You can access it by using the Stack select field in the Environment UI:

stack_stable-v4.png

It's best practice to upgrade your Engine Yard Gentoo 12.11 (stable-v4) stack regularly for the latest security and product updates. This week's updates:

  • Upgrades MySQL 5.6 to 5.6.22: See upgrade instructions for minor database version changes.
  • Enhances collectd monitoring and performance graphs for ext4 and swap devices, removes redundant mysql check.
  • Corrects database log directory path in system "Message of the Day" displayed when logging into instances via SSH.

For more information on Engine Yard Gentoo 12.11, see the Engine Yard Gentoo 12.11 docs.


If you have feedback or questions about this page, add a comment below. If you need help, submit a ticket with Engine Yard Support.

Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request

Comments

  • Avatar
    Dennis Bell

    Hotfix issued for issue affecting non-ruby environments trying to upgrade to the March 17th, 2015 update.

  • Avatar
    Dennis Bell

    Hotfix issued for addressing OpenSSL security vulnerabilities.

Please sign in to leave a comment.

Powered by Zendesk