Engine Yard Developer Center

Engine Yard Release Notes- April 2018

Engine Yard Stack Release Notes for April 18th, 2017

Minor: Engine Yard Gentoo 12.11 stack upgrade

Action: You apply the following changes the next time you click the Upgrade button for your Engine Yard Gentoo 12.11 environment.

Note: For clarity, since we now have 2 Gentoo stacks, we refer to this stack as the Engine Yard Gentoo 12.11 stack. You can access it by using the Stack select field in the Environment UI:stable-v4-2.0.130

stack_stable-v4.png

It's best practice to upgrade your Engine Yard Gentoo 12.11 (stable-v4) stack regularly for the latest security and product updates.

  • Upgraded dev-perl/config-general-2.500.0 to =dev-perl/config-general-2.510.0.

For more information on Engine Yard Gentoo 12.11, see the Engine Yard Gentoo 12.11 docs.

 


 

Engine Yard Stack Release Notes for April 12th, 2017

Minor: Engine Yard Gentoo 2016 stack upgrade

Action: You apply the following changes the next time you click the Upgrade button for your Engine Yard Gentoo 2016 environment.

Note: For clarity, since we now have 2 Gentoo stacks, we refer to this stack as the Engine Yard Gentoo 2016 stack. You can access it by using the Stack select field in the Environment UI: stable-v5-3.0.41

It's best practice to upgrade your Engine Yard Gentoo 2016 (stable-v5) stack regularly for the latest security and product updates. This week's updates:

  • Update on Nginx config for handling fonts.
  • Updated passenger config detach change.
  • Minor cleanup to collectd recipe dependency package directives.
  • New instances booted using this stack will use EYGL AMI revision 2016.06.018.final!. Changes since EYGL AMI 2016.06.16.final:
      • =dev-perl/Config-General-2.600.0, dev-perl/DBD-Pg-3.4.2, dev-perl/TimeDate-2.300.0, dev-perl/regexp-common-2013031301.0.0 are now included by default on the OS image.
      • =sys-libs/glibc-2.22-r4 has been upgraded to =sys-libs/glibc-2.22-r5 addressing support for the Ghanaian (ak_GH) locale.
      • =dev-libs/libyaml-0.1.6-r1 has been upgraded to =dev-libs/libyaml-0.1.7 addressing security issues.
      • =dev-ruby/rubygems-2.6.4 has been upgraded to =dev-ruby/rubygems-2.6.14 addressing multiple security issues.
      • =dev-lang/ruby-2.2.6 has been upgraded to =dev-lang/ruby-2.2.9 addressing multiple security issues.
      • =dev-lang/ruby-2.3.3 has been upgraded to =dev-lang/ruby-2.3.6 addressing multiple security issues.
      • =dev-ruby/did_you_mean-1.0.1 has been upgraded to =dev-ruby/did_you_mean-1.0.2 in support of the aforementioned Ruby updates.

 

 

For more information on Engine Yard Gentoo 2016, see the Engine Yard Gentoo 2016 docs.

 


 

Engine Yard Stack Release Notes for April 8th, 2017

Minor: Engine Yard Gentoo 12.11 stack upgrade

Action: You apply the following changes the next time you click the Upgrade button for your Engine Yard Gentoo 12.11 environment.

Note: For clarity, since we now have 2 Gentoo stacks, we refer to this stack as the Engine Yard Gentoo 12.11 stack. You can access it by using the Stack select field in the Environment UI:stable-v4-2.0.129

stack_stable-v4.png

It's best practice to upgrade your Engine Yard Gentoo 12.11 (stable-v4) stack regularly for the latest security and product updates.

  • Resolves an issue with detecting a crashed ntpd process.
  • Rewrites candidate_version determination in Chef's Chef::Provider::Package::Portage class for increased speed and reduced complexity/error-chance.

For more information on Engine Yard Gentoo 12.11, see the Engine Yard Gentoo 12.11 docs.

 


 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Please sign in to leave a comment.

Powered by Zendesk