Engine Yard Developer Center

RubyGems versions on stable-v6

For the stable-v6 stack we've taken the decision to remove the RubyGems version selector from the Environment creation and edit forms and instead utilise the RubyGems version packaged with the Ruby installation. For the v6 stack the Ruby installation is handled by ruby-install.

This has the advantage of ensuring the RubyGems version is kept up to date via the updated Ruby packages published through the Stack upgrades, rather than relying on being manually set as previously.

Therefore our recommended method to bump the RubyGems version is to apply any awaiting Stack upgrades. Should applying the Upgrades not be a practical option, then custom Chef can be used to upgrade the RubyGems installation:

Add this block to the end of cookbooks/ey-custom/recipes/after-main.rb (replacing x.x.x with the required version):

execute "Update to rubygems x.x.x" do
  command "gem install -v x.x.x rubygems-update && update_rubygems"
end
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Please sign in to leave a comment.

Powered by Zendesk